All systems operational

Resolved
Dashboard networking issue

Started
May 31, 2023 at 7:30 AM
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
Web Dashboard
Mobile App
  • Resolved

    This incident has been resolved.

  • Identified

    Cloudflare identified the issue and is currently working for a fix.

  • Investigating

    Cloudflare, our CDN provider, is currently experiencing issues in the APAC and SAM regions:

    https://www.cloudflarestatus.com/incidents/28lv1y81cvh9

    This will cause our web, desktop and mobile app to work slowly or not loading at all from those regions. We'll keep posting updates.