Resolved
callbell.eu domain issues

Started
November 28, 2022 at 3:21 PM
Status
Resolved after 10 minutes

Impact

Major outage
Affected
Mobile App
Web Dashboard
  • Resolved
    November 28, 2022 at 3:31 PM

    A fix was released, our team will keep monitoring the situation in the upcoming hours.

  • Investigating
    November 28, 2022 at 3:21 PM

    Currently the web and mobile application are not accessible. Our team is working for a prompt fix.